All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX NOTIFICATION: Exchange Transaction Delays
Incident Report for GHX - Customer Status - All
Resolved
Dear GHX Customer,

The issue that was causing exchange delays has been resolved - all transactions are processing in real-time with no delays or errors.

As your trusted partner for effective, efficient and reliable supply chain automation, we take any disruption to our service very seriously. We sincerely apologize for any inconvenience this issue has caused you. Please be assured that we’re actively working to apply the learnings from this incident to help improve performance and prevent future occurrences of this issue.


If you have additional questions or concerns about this disruption, or any other matter related to our technology, data or services, please contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.



Thank you,

GHX Customer Care Team
Posted Aug 25, 2023 - 16:51 MDT
Investigating
Dear GHX Customer,

We are experiencing a disruption with the GHX Exchange that is impacting our customers. The GHX Customer Care team is diligently working to identify the problem and we will provide you with regular updates.

Below please find a description of what we know so far:


OVERVIEW

* We have experienced a recurrence of the condition that created exchange delays earlier today.
* A portion of transactions were delayed for up to 25 between 1:50 pm and 2:50 pm Mountain Time.
* The team continues working to correct the issue as quickly as possible.
* We will continue to provide updates until the issue is fully resolved.

As always, we are here to answer your questions and address any further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.

GHX is committed to facilitating reliable supply chain transactions for the healthcare community. We understand the critical role we play in your business operations and sincerely apologize for any inconvenience this issue has caused you.

Thank you,
GHX Customer Care Team
Posted Aug 25, 2023 - 15:02 MDT
This incident affected: Exchange.