All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX Notification: Gfax Parked Orders

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customer,

GHX teams have resolved the issue that caused a higher amount of Gfax purchase orders to park in IBR due to an incorrect account number today at 1:16 PM MT. Gfax Purchase Orders processed after 1:16 PM MT should process as expected. If you would like any orders to be reprocessed through the look-up process for your account list, please contact GHX Support at support@ghx.com, and they will resend them.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the “Customer Support” tab on the GHX Community at www.ghx.com/community .

Thank you,
GHX Customer Care Team
Posted May 04, 2026 - 14:00 MDT

Investigating

Dear GHX Customer,

GHX teams are currently troubleshooting an issue that began this morning, causing a higher amount of Gfax purchase orders to park in IBR for an incorrect account number. Teams are working to resolve this as quickly as possible. We will continue to provide additional updates as available.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the “Customer Support” tab on the GHX Community at www.ghx.com/community . We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
Posted May 04, 2026 - 13:37 MDT
This incident affected: G-Fax.