All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX document processing delays and application visibility

Incident Report for GHX - Customer Status - All

Resolved

RESOLVED

Transactions and application visibility have been in real-time since 11:22am MST on 2/13, and the incident is now resolved.

GHX teams were called to major incident at approximately 12:18AM MST.  As transaction volumes increased during business hours, the Exchange experienced intermittent delays of up to 35 minutes in processing transactions. This included Orders, Order Confirmations, Advanced Ship Notifications, and Invoices.

GHX application visibility was also impacted by these document processing delays. Affected applications include: My Exchange, Procure, NuVia, E-Invoicing, IBR, Metatrade, and GFax.

The major incident team successfully restored system performance by improving write concurrency performance on a critical database. The team is implementing additional application-level safeguards to prevent similar contention in the future.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Feb 13, 2026 - 15:26 MST

Update

ISSUE UPDATE:

The major incident response team remains actively engaged, and we have not experienced any delays since 11:22 am Mountain. This includes Orders, Order Confirmations, Advanced Ship Notifications, and Invoices.  Affected applications include: My Exchange, Procure, NuVia, E-Invoicing, IBR, Metatrade, and GFax.

We continue to research and monitor, and will communicate updates as status changes and information becomes available.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Posted Feb 13, 2026 - 13:28 MST

Update

Good Morning,

ISSUE UPDATE:

GHX continues to experience transactions and application visibility intermittently backing up with delays nearing 30 minutes before completely recovering. This includes Orders, Order Confirmations, Advanced Ship Notifications, and Invoices. Affected applications include: My Exchange, Procure, NuVia, E-Invoicing, IBR, Metatrade, and GFax.

The major incident response team is actively engaged. We will continue to communicate updates as status changes and information becomes available.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Feb 13, 2026 - 11:28 MST

Monitoring

Good Morning,

ISSUE UPDATE:

Transactions and application visibility are currently real-time.

GHX teams are continuing to troubleshoot and monitor an issue that began at approximately 12:18 AM MST, causing intermittent delays of up to 25 minutes in transaction processing through the Exchange. This includes Orders, Order Confirmations, Advanced Ship Notifications, and Invoices.

GHX application visibility was also impacted by these document processing delays. Affected applications include: My Exchange, Procure, NuVia, E-Invoicing, IBR, Metatrade, and GFax. There is currently no delay in transaction processing or visibility. We continue to monitor and research at this time.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.
Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Feb 13, 2026 - 09:57 MST

Identified

Good Morning,

ISSUE SUMMARY:

GHX teams are currently troubleshooting an issue that began at approximately 12:18AM MST and is causing an intermittent delay of up to 25 minutes in transaction processing through the Exchange. This includes Orders, Order Confirmations, Advanced Ship Notifications, and Invoices.

GHX application visibility is also impacted by document processing delays. Affected applications include: My Exchange, Procure, NuVia, E-Invoicing, IBR, Metatrade, and GFax.  The current delay in transaction processing is approximately 25 minutes.  There is currently no ETR (Estimated Time to Repair).

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Feb 13, 2026 - 09:03 MST
This incident affected: My Exchange Provider, G-Fax, Exchange Transaction Processing, Procure, CCXpert, IBR (Intelligent Business Rules), eInvoicing Supplier, eInvoicing Provider - Application, NuVia, and CPlus 4.0.