All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

CCXpert Application Performance Degraded

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customer,

GHX teams have resolved the intermittent performance issues in the CCXpert application that began this morning at approximately 7:20 AM MT. Local contracts and reporting are now loading as expected.

As always, we are here to answer your questions and address further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the “Customer Support” tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care Team
Posted May 04, 2026 - 14:18 MDT

Investigating

Dear GHX Customer,

GHX is currently investigating intermittent performance issues in the CCXpert application that began this morning at approximately 7:20 AM MT. Some users may experience local contracts loading incorrectly and delayed report loading, or timing out. We will provide an update as soon as additional information becomes available.

As always, we are here to answer your questions and address further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the “Customer Support” tab on the GHX Community at https://ghx.my.site.com/s/.

GHX is committed to facilitating reliable supply chain transactions for the healthcare community. We understand our critical role in your business operations and sincerely apologize for any inconvenience this issue has caused you.

Thank you,
GHX Customer Care Team
Posted May 04, 2026 - 11:50 MDT
This incident affected: CCXpert.