All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX Notification: RESOLVED: Transaction Updates - Posting Delay

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customers,


STATUS UPDATE:
GHX teams identified the root cause of the issue impacting My Exchange updates and IBR order visibility and deployed corrective measures that have fully resolved the issue.

Monitoring for the past 24 hours has confirmed normal processing and transaction-status visibility with no further impact on My Exchange updates or IBR processing.


If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.


Thank you,
GHX Customer Care Team
Posted Mar 28, 2025 - 14:44 MDT
This incident affected: My Exchange Provider, IBR (Intelligent Business Rules), and My Exchange Website.