All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

eInvoicing Provider Application - Data Capture Delays

Incident Report for GHX - Customer Status - All

Resolved

Dear Valued eInvoicing Provider Customer,

Please ensure the necessary users in your organization are informed of the information below.

Issue Description: GHX has resolved the issue that impacted invoice data capture processing for some customers. Service has now been restored, and GHX is processing affected transactions.

NOTE: Customers who received invoice email bounce backs are asked to verify GHX receipt and reprocess these transactions to GHX as necessary.

GHX understands the difficulties this issue may have caused, and we want to assure you that we greatly value your partnership. We appreciate your patience during this time.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care
Posted Aug 20, 2025 - 13:52 MDT

Investigating

Dear Valued eInvoicing Provider Customer,

You are receiving this email because you are an Administrator for your account, or you have requested be included on incident communications. Please ensure the necessary users in your organization are informed of the information below.

Issue Description: GHX is actively investigating an issue that is impacting the invoice data capture processing for some customers. We will provide updates as soon as they become available.

GHX is aware of the difficulties this is causing. Please know that we highly value your partnership and patience.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care
Posted Aug 20, 2025 - 13:10 MDT
This incident affected: eInvoicing Provider - Application.