All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX System Status Message: GFax Processing Delay

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customer,

GHX has resolved the issue impacting GFax order processing. All impacted transactions have now been successfully processed and normal processing has been restored.

If you manually submitted any delayed orders, it’s possible that duplicate orders were sent. We recommend reviewing your orders in the Exchange to ensure no duplicates are sent to your suppliers.

We recognize the impact this issue may have had on your operations and appreciate your understanding throughout the resolution process.

If you continue to experience any issues submitting invoices, or if you have questions regarding this incident, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request through the GHX Community Customer Support portal.

Thanks,
GHX Customer Care Team
Posted Jun 26, 2026 - 14:35 MDT

Monitoring

Dear GHX Customer,

GHX Technical teams have fully resolved the issues impacting GFax order processing, and all affected transactions have been processed.  New transactions sent to GFax are processing without intervention.  GHX will keep the incident open at this time and will continue to monitor system performance with the fix in place.

If you manually submitted any delayed orders, it’s possible that duplicate orders were sent. We recommend reviewing your orders in the Exchange to ensure no duplicates are sent to your suppliers.

We recognize the impact this issue may have had on your operations and appreciate your understanding throughout the resolution process.

We sincerely regret any inconvenience caused during this incident.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the GHX Support tab on the GHX Community.

Thanks,
GHX Customer Care
Posted Jun 23, 2026 - 12:28 MDT

Update

Dear Customer,

GHX Technical teams have successfully deployed a corrective fix to resolve a significant portion of the GFax order-processing issues that were under investigation. Validation activities have been completed, and the impacted transactions have processed.  GHX continues to troubleshoot the remaining intermittent issues.  Additional updates will be sent as soon as new information is available.

If you manually submitted any delayed orders, it’s possible that duplicate orders were sent. We recommend reviewing your orders in the Exchange to ensure no duplicates are sent to your suppliers.

We recognize the impact this issue may have had on your operations and appreciate your understanding throughout the resolution process.

We sincerely regret any inconvenience caused during this incident.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the GHX Support tab on the GHX Community.

Thanks,
GHX Customer Care Team
Posted Jun 23, 2026 - 11:26 MDT

Update

Dear GHX Customer,

Issue Update: GHX teams are currently reviewing and confirming the remediation changes for the GFax order-processing system. Restoration of full functionality remains the top priority, with efforts underway to bring services back to normal at the earliest. We will continue to share progress as work continues.

We appreciate your patience and understanding.

For any questions or support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or raise a request via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thanks,
GHX Customer Care Team
Posted Jun 23, 2026 - 09:04 MDT

Update

Dear GHX Customer,

Issue Update: GHX Technical teams are actively working on a corrective fix for the issue affecting the GFax order-processing system. The team remains focused on restoring standard operations as quickly as possible. At this time, a confirmed deployment schedule is not yet available. We will continue to provide updates as progress develops.

We appreciate your patience and understanding as we work through this issue, and we regret any inconvenience caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thanks,
GHX Customer Care
Posted Jun 23, 2026 - 05:10 MDT

Update

Dear GHX Customer,

Issue Update: GHX Technical teams are actively validating the corrective fix to address the issue affecting the GFax order-processing system and are focused on restoring standard operations as soon as possible. A confirmed deployment schedule is not yet available. We will keep you informed as the work advances.

We appreciate your patience and understanding as we work through this issue, and we regret any inconvenience caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Jun 22, 2026 - 17:12 MDT

Update

Dear GHX Customer,

Issue Update: GHX Technical teams have identified and developed a fix for the issue impacting the GFax order-processing system, which began this morning at approximately 2:30 AM MT. The team is currently testing the fix and working to restore normal processing as quickly as possible.

At this time, an estimated time for deployment is not yet available. We will continue to provide updates as additional information becomes available.

We highly value your partnership and appreciate your patience while we work to resolve this issue. GHX sincerely apologizes for any inconvenience this may cause.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Jun 22, 2026 - 15:33 MDT

Identified

Dear GHX Customer,

Issue Update: GHX Technical teams have identified a fix for the issue impacting the GFax order-processing system, which began this morning at approximately 2:30 AM MT. The team is currently preparing to implement the fix and is working to restore normal processing as quickly as possible.

At this time, an estimated time for deployment is not yet available. We will continue to provide updates as additional information becomes available.

We highly value your partnership and appreciate your patience while we work to resolve this issue. GHX sincerely apologizes for any inconvenience this may cause.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Jun 22, 2026 - 14:31 MDT

Update

Dear GHX Customer,

GHX is continuing to investigate the issue affecting the Gfax order-processing system, which began this morning at approximately 2:30 AM MT.  A subset of orders are delayed due to the processing issues. We will provide additional updates as soon as they become available.

GHX takes our responsibility to you and your trading partners very seriously. We apologize again for this disruption, and we assure you that we are actively seeking a solution.

 As always, we are here to answer your questions and address any further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.
Posted Jun 22, 2026 - 10:37 MDT

Investigating

Dear GHX Customer,

GHX is currently investigating an issue affecting the Gfax order-processing system, which began this morning at approximately 2:30 AM MT. Customers may receive a "Attachment Conversation Failed Notice" notification when sending orders to G-Fax. A subset of orders are delayed due to the processing issues. We will provide additional updates as soon as they become available.

GHX takes our responsibility to you and your trading partners very seriously. We apologize again for this disruption, and we assure you that we are actively seeking a solution.

 As always, we are here to answer your questions and address any further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.
Posted Jun 22, 2026 - 08:26 MDT
This incident affected: G-Fax.