All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

AWS Incident – Monitoring for Potential Impact to GHX Services

Incident Report for GHX - Customer Status - All

Resolved

Good Afternoon,

As of 4:53 p.m. MDT last evening, AWS resources have confirmed that all services have been fully restored. The GHX team has continued to monitor the status of the Exchange throughout last night and this morning to ensure that our applications remain healthy.
Transactions through the Exchange continue processing in real time, and all GHX applications affected by the AWS incident are operational and available to users.

Our support team worked diligently overnight to ensure that any transactions impacted by the AWS incident were successfully resent or notifications delivered to the appropriate trading partner. If your organization did not receive an expected document or documents, please contact our support team to resolve the issue.

If you have any questions or need assistance, please reach out to GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or submit a service request online through the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care Team
1315 W Century Dr., Suite 100
Louisville, CO 80027
Support@GHX.com
1-800-968-7449
Posted Oct 21, 2025 - 12:17 MDT

Update

Good evening,

The GHX team is actively monitoring the ongoing AWS incident. We have successfully resent all documents that were impacted or delayed due to this incident. The Exchange is now processing documents in real time, and our team will continue to oversee the situation until AWS confirms that the issue has been fully resolved.

We would like to inform you that all GHX applications affected by the AWS incident are operational and available for users.

If you have any questions or need assistance, please reach out to GHX Customer Care at 1-800-YOUR-GHX (1-800-968-7449), or submit a service request online by visiting the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will keep you updated via email until this issue is resolved.

Thank you for your understanding.

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Oct 20, 2025 - 16:57 MDT

Update

The GHX team continues to monitor the ongoing AWS incident actively.

Customers experienced delays with transactions in their internal systems reaching the GHX Exchange due to the AWS incident. GHX resources are currently reporting that previously queued messages are now processing into the GHX Exchange. Documents impacted by this issue were delayed for about 2 hours and GHX’s Exchange is currently working through the backlog of delayed transactions.

Documents processing through GFax are also delayed due to the AWS incident.

You may experience intermittent issues including (general slowness, problems with data loading, contract update delays) with the following applications: SCA, CCX, Data Connect, Nuvia, Provider Intelligence, Vendormate and Procure. We continue to investigate any potential effects on other document processing and related applications.

Additional updates will be provided as more information becomes available or once the issue is fully resolved.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,
GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Oct 20, 2025 - 14:28 MDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:19 MDT

Update

Good Afternoon,

ISSUE SUMMARY:

The GHX team continues to actively monitor the ongoing AWS incident. Core Exchange transaction processing and delivery are functioning normally with no backlog or delays, including Gfax orders.

You may experience intermittent issues including (general slowness, issues with data loading, contract update delays) with the following applications: SCA, CCX, Data Connect, Nuvia, Provider Intelligence, and Procure. We continue to investigate any potential effects on other document processing and related applications. Additional updates will be provided as more information becomes available or once the issue is fully resolved.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Oct 20, 2025 - 12:11 MDT

Monitoring

Good Morning,

ISSUE SUMMARY:

The GHX team is aware of and actively monitoring the ongoing AWS incident. As of 07:00 EST, core document processing is functioning normally. Our teams have completed resending a small number of documents that errored earlier this morning and continue to monitor for any further impact. We are also investigating any potential effects on other document processing and related applications. Additional updates will be provided as more information becomes available or once the issue is fully resolved.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Oct 20, 2025 - 09:02 MDT
This incident affected: My Exchange Provider, G-Fax, Exchange Transaction Processing, Procure, Procurement Suite, CCXpert, IBR (Intelligent Business Rules), eInvoicing Supplier, eInvoicing Provider - Application, NuVia, Vendormate Credentialing, Vendormate Vendor Manager, Vendormate Contract Manager Xpert, Vendormate Compliance Document Manager, MetaTrade, My Exchange Website, Registration Center, Web Direct, Health conneXion, Market Intelligence, Provider Intelligence, CPlus 4.0, Oracle, Infor, Workday, Prodigo, Syft, Prodigo Xchange, Price Sync, Order Trust, Data Connect, Supply Chain Analytics, and EU-Test-Incident.