All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX System Status Message: GFax Processing Delay
Incident Report for GHX - Customer Status - All
Resolved
The issue that was causing delays for GFax orders has been resolved as of 8:00 pm Mountain Time on Tuesday evening, December 5.
We expect no further delays for GFax orders going forward.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community .

Thank you,

GHX Customer Care Team
Posted Dec 06, 2023 - 11:12 MST
Update
Dear GHX Gfax customer,

the GFax processing team continues to work toward resolving delays with order processing:


* Approximately 20% of overall GFax volume has been delayed past 60 minutes
* The team expects to resume normal processing time for all orders by 8:00pm Mountain Time

We will continue to provide updates until the issue is fully resolved.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.


sincerely,

GHX Customer Care Team
Posted Dec 04, 2023 - 15:26 MST
Identified
Dear GHX customer,

GHX is experiencing a slight delay in processing GFax purchase orders.
Approximately 14% of fax orders are delayed up to 60 minutes past the standard delivery turnaround time of one hour.

We are working with our fax processing team to correct the delay, and will be monitoring the situation closely until the issue is fully resolved.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community .

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Dec 04, 2023 - 11:08 MST
This incident affected: G-Fax.