All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX REESTABLISHES CONNECTION TO HENRY SCHEIN
Incident Report for GHX - Customer Status - All
Resolved
GHX Customers,

Yesterday (December 8th), GHX pre-emptively disabled our connection to Henry Schein. Following an immediate discussion with Henry Schein, which provided information as to the safety of its system, GHX Exchange was reestablished at 7:00 pm ET on December 8th.

GHX will continue to monitor its platform to protect GHX systems and our customers against cybersecurity threats.

As your trusted partner for efficient and reliable supply chain automation, we take any disruption to your service very seriously. We recognize the disruption and inconvenience this caused while we worked to obtain more information. For that we apologize, and we are grateful to Henry Schein for their prompt collaboration yesterday to bring resolution.

Trading partners of Henry Schein who have questions about the status of orders placed on December 8th between 8:00 am and 7:00 pm MT are advised to contact Henry Schein Customer Service at 1-800-472-4346.

As always, please contact support@GHX.com if there’s anything we can do to help you.
Posted Dec 09, 2023 - 12:36 MST
Monitoring
Ghx Customers,

The GHX Security Team is aware of ongoing cybersecurity incidents Henry Schein is experiencing. 
 
GHX is disabling all inbound and outbound connections between Henry Schein and GHX. All orders submitted to and from Henry Schein will be stopped at the GHX Exchange and the Prodigo Marketplace. Please reach out to Henry Schein directly regarding questions about orders you may have sent or received from Henry Schein since 8:00 a.m. Mountain Standard Time today, December 8. 
 
GHX is actively monitoring this situation and has not identified any indication of this cybersecurity incident affecting the GHX network or other customers. If you are aware of any impact to your company as a result of the incident, please contact support@GHX.com.  
 
We are currently exploring alternatives for how orders can be safely transmitted and will be in touch with details as they become available. 
 
We will provide updates as we learn more. 

Thank you,
GHX Customer Care Team
Posted Dec 08, 2023 - 10:24 MST
This incident affected: Exchange.