All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

My Exchange - Document Status visibility delay and CCXpert Contract Upload Delay

Incident Report for GHX - Customer Status - All

Resolved

Good Afternoon,

GHX teams have fully resolved the issue that caused delays in document status visibility updates in My Exchange and Intelligent Business Rules as well as delays in CCXpert contract loading functionality. All transactions sent to GHX are now visible in real time. We apologize for any inconvenience these delays may have caused.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/ .

Thank you,
GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
Support@GHX.com
1.800.968.7449
Posted Jun 23, 2025 - 15:46 MDT

Monitoring

Good Afternoon,

ISSUE SUMMARY:
GHX teams have addressed an issue that has caused a delay of up to 232 minutes in Document Status visibility updates. Teams
will continue to monitor document visibility delay to ensure that real-time Visibility is achieved.

GHX applications also impacted by document Status update delays, include:
-My Exchange: The delay in transaction visibility is approximately 178 minutes.
- CCXpert: Delay in Contracts loading to the CCXpert Portal.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the “Customer Support” tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Jun 23, 2025 - 13:48 MDT
This incident affected: CCXpert and My Exchange Website.