All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX NOTIFICATION: User Access To GHX Applications

Incident Report for GHX - Customer Status - All

Monitoring

Good Afternoon,

The following notification is being sent to [all GHX customers]:

ISSUE SUMMARY:

Access to GHX applications through the SSO has been restored. GHX technical teams are continuing to monitor the system impacted by this issue and are actively investigating the issue that prevented some users from logging in to GHX applications earlier today. Transaction Processing and delivery are not affected, this issue was limited to user access to online applications only.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Apr 24, 2026 - 12:43 MDT

Update

Good Afternoon,

The following notification is being sent to [all GHX customers]:

ISSUE SUMMARY:

GHX technical teams are continuing to troubleshoot an issue that is preventing some users from logging in to GHX applications. Transaction Processing and delivery are not affected, this is limited to user access to online applications only.

We are working to resolve the issue as quickly as possible and will continue to provide updates until it is fully resolved.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Apr 24, 2026 - 12:09 MDT

Investigating

Good Afternoon,

The following notification is being sent to [all GHX customers]:

ISSUE SUMMARY:

GHX technical teams are currently troubleshooting an issue that is preventing some users from logging in to GHX applications. Transaction Processing and delivery are not affected, this is limited to user access to online applications only.

We are working to resolve the issue as quickly as possible and will continue to provide updates until it is fully resolved.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Apr 24, 2026 - 11:39 MDT
This incident affects: My Exchange Provider, G-Fax, Exchange Transaction Processing, Procure, CCXpert, IBR (Intelligent Business Rules), eInvoicing Supplier, eInvoicing Provider - Application, NuVia, Vendormate Credentialing, Vendormate Vendor Manager, Vendormate Contract Manager Xpert, Vendormate Compliance Document Manager, My Exchange Website, Registration Center, Health conneXion, Data Connect, and Supply Chain Analytics.