All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX Integration Environment (INT) Disaster Recovery Excercise

Scheduled for Aug 20, 08:00 - 13:00 MDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 06, 2026 - 08:51 MDT

Scheduled

Dear Valued Customer,

You are receiving this message because you have been identified as a user of GHX's Integrations environment.

GHX will be conducting disaster recovery testing in our Integrations environment (INT) on Thursday, August 20th from 8:00 AM – 1:00 PM Mountain Time. The Integrations environment will be unavailable during this window.

To avoid any disruption to your testing activities, please ensure all work in the Integrations environment is completed by 6:00 AM Mountain Time on August 20th.

If you have any questions or require additional support, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449).

Thank you,
GHX
Posted Aug 06, 2026 - 08:48 MDT
This scheduled maintenance affects: My Exchange Provider, G-Fax, Exchange Transaction Processing, Procure, CCXpert, IBR (Intelligent Business Rules), eInvoicing Supplier, eInvoicing Provider - Application, NuVia, MetaTrade, My Exchange Website, Registration Center, and Data Connect.