Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.
ISSUE RESOLVED: GHX has successfully resolved the issue affecting Exchange transaction processing.
The following have been restored to normal operation: • Suppliers using IBR — Parked Purchase Orders can now be released normally in My Exchange • Invoice processing — Invoices on the Exchange are being processed successfully • MyExchange Visibility — The red banner and 500 errors when accessing the Orders and Transactions tabs have been resolved • Document Reconciliation — All document reconciliation is complete
If you believe you have submissions that were impacted and require follow-up, please contact GHX Customer Care.
We apologize for any inconvenience and thank you for your patience and partnership.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team
Posted Jul 28, 2026 - 16:29 MDT
Update
Dear GHX Customer,
ISSUES RESOLVED: GHX has successfully resolved the issue affecting Exchange transaction processing.
The following have been restored to normal operation:
Suppliers using IBR — Parked Purchase Orders can now be released normally in My Exchange Invoice processing — Invoices on the Exchange are being processed successfully MyExchange Visibility — The red banner and 500 errors when accessing the Orders and Transactions tabs have been resolved
ISSUES OUTSTANDING: Our teams continue to work on reprocessing affected transactions. If you believe you have orders that were impacted and require follow-up, please contact GHX Customer Care.
We apologize for any inconvenience and thank you for your patience and partnership.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team
Posted Jul 28, 2026 - 15:54 MDT
Update
Dear GHX Customer,
ISSUES RESOLVED: GHX has successfully resolved the issue affecting Exchange transaction processing.
The following have been restored to normal operation:
Suppliers using IBR — Parked Purchase Orders can now be released normally in My Exchange Invoice processing — Invoices on the Exchange are being processed successfully MyExchange Visibility — The red banner and 500 errors when accessing the Orders and Transactions tabs have been resolved
ISSUES OUTSTANDING: Our teams continue to work on reprocessing affected transactions. If you believe you have orders that were impacted and require follow-up, please contact GHX Customer Care.
We apologize for any inconvenience and thank you for your patience and partnership.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team
Posted Jul 28, 2026 - 15:07 MDT
Update
Dear GHX Customer,
ISSUES RESOLVED: GHX has successfully resolved the issue affecting Exchange transaction processing.
The following have been restored to normal operation:
Suppliers using IBR — Parked Purchase Orders can now be released normally in My Exchange Invoice processing — Invoices on the Exchange are being processed successfully MyExchange Visibility — The red banner and 500 errors when accessing the Orders and Transactions tabs have been resolved
ISSUES OUTSTANDING: Our teams continue working through the reprocessing of affected transactions. If you believe you have orders that were impacted and require follow-up, please contact GHX Customer Care.
We apologize for any inconvenience and thank you for your patience and partnership.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team
Posted Jul 28, 2026 - 14:19 MDT
Update
Dear GHX Customer,
ISSUES RESOLVED: GHX has successfully resolved the issue affecting Exchange transaction processing.
The following have been restored to normal operation:
Suppliers using IBR — Parked Purchase Orders can now be released normally in My Exchange Invoice processing — Invoices on the Exchange are being processed successfully MyExchange Visibility — The red banner and 500 errors when accessing the Orders and Transactions tabs have been resolved
Outstanding: Our teams continue working through the reprocessing of affected transactions. If you believe you have orders that were impacted and require follow-up, please contact GHX Customer Care.
We apologize for any inconvenience and thank you for your patience and partnership.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team
Posted Jul 28, 2026 - 13:33 MDT
Monitoring
GHX is investigating an issue impacting certain transactions on the Exchange. Purchase order processing is not impacted except for suppliers using IBR. The impact includes:
Suppliers are unable to release orders parked in IBR Invoices on the Exchange are failing to process MyExchange Visibility: Customers will intermittently see a red banner or a 500 error when attempting to access MyExchange.
Our engineering and database teams have been engaged and are actively working to identify and resolve the root cause as quickly as possible. We will provide updates as more information becomes available.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-968-7449 or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team
Posted Jul 28, 2026 - 12:43 MDT
Identified
GHX is investigating an issue impacting certain transactions on the Exchange. Purchase order processing is not impacted except for suppliers using IBR. The impact includes:
Suppliers are unable to release orders parked in IBR Invoices on the Exchange are failing to process MyExchange Visibility: Customers will intermittently see a red banner or a 500 error when attempting to access MyExchange.
Our engineering and database teams have been engaged and are actively working to identify and resolve the root cause as quickly as possible. We will provide updates as more information becomes available.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-968-7449 or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team
Posted Jul 28, 2026 - 12:00 MDT
Investigating
Dear GHX Customer,
You are receiving this email because you are an account Administrator or have requested to receive incident communications. Please share this update with the appropriate users in your organization.
ISSUE NOTIFICATION: GHX is currently investigating an issue affecting Exchange transaction processing. Users may be experiencing the following:
Transaction failures — Invoices on the Exchange are failing to process Parked PO release failures — Suppliers are unable to release parked Purchase Orders from IBR (Invoice-Based Routing) in My Exchange MyExchange Visibility — Customers will experience a red banner or a 500 error when attempting to access My Exchange.
Our engineering and database teams have been engaged and are actively working to identify and resolve the root cause. We will provide updates as more information becomes available.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-968-7449 or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team
Posted Jul 28, 2026 - 11:19 MDT
This incident affected: My Exchange Provider, Exchange Transaction Processing, and IBR (Intelligent Business Rules).