All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX GFax document processing delays

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customer,

ISSUE RESOLVED: GHX has successfully resolved the issue affecting GFax document processing.

The following has been restored to normal operation:

GFax Document Processing — All documents, including those submitted earlier this morning that experienced delays, have been processed, and all current documents are being processed in real time.

Our teams have completed the processing of all affected documents. If you believe you have submissions that were impacted and require follow-up, please contact GHX Customer Care.

We apologize for any inconvenience and thank you for your patience and partnership.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request via the "Customer Support" tab on the GHX Community at ghx.my.site.com.

Thank you,
GHX Customer Care Team
Posted Jul 30, 2026 - 12:48 MDT

Investigating

Dear GHX Customer,

ISSUE NOTIFICATION: GHX is currently investigating an issue affecting GFax document processing, which began at 07:22 MST. Users may have experienced the following:

GFax Document Delays — A subset of documents submitted via GFax earlier this morning may have experienced minor processing delays and may not yet be visible within expected timeframes. All new GFax traffic is processing in real time and is not impacted.

Our engineering teams have been engaged and are actively working to resolve the delay for affected documents. We will provide updates as more information becomes available.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,
GHX Customer Care Team
Posted Jul 30, 2026 - 12:01 MDT
This incident affected: G-Fax.