All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX NOTIFICATION - Transaction Processing Delays

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customer,

GHX has resolved the issue causing delays in the delivery of Orders, Order Confirmations, Advanced Ship Notifications (ASNs), and Invoices.

The issue was identified on June 24, 2026, at 4:56 AM MDT and was resolved on June 24, 2026, at 7:14 AM MDT.

As a result of this issue, some transactions may not have been successfully sent due to an error in Message Delivery Notification (MDN) processing. Customers should review any transactions in this timeframe that did not receive an MDN and resend them as needed.

GHX teams have restored normal processing and continue to monitor the environment to ensure stability.

If you have any questions or require assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request through the Customer Support section of the GHX Community.

Thank you for your patience and partnership.
GHX Customer Care Team
Posted Jun 24, 2026 - 07:48 MDT

Investigating

Dear GHX Customer,

Issue Summary: GHX teams are actively investigating an issue causing delays in AS2 transaction deliveries, with delays up to 90 minutes.

Affected transaction types include:

* Orders
* Order Confirmations
* Advanced Ship Notifications (ASNs)
* Invoices

Our teams are working to identify the root cause and restore normal processing as quickly as possible.

If you have any questions or require assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request through the Customer Support section of the GHX Community.

We will continue to provide updates until the issue has been resolved. Thank you for your understanding.

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Jun 24, 2026 - 07:21 MDT
This incident affected: Exchange Transaction Processing.