All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX NOTIFICATION: Marketplace User Access

Incident Report for GHX - Customer Status - All

Update

Dear GHX Customer,

UPDATE: We are aware that some users are still experiencing issues accessing the GHX Marketplace website and applications following the previous fix. We apologize for the continued disruption.

If you're still experiencing issues, please ask your IT or Networking team to clear the caches on any network-level equipment. We're also happy to join a call to provide assistance if that would be helpful. Please reach out to support to coordinate this.

We apologize for any inconvenience and thank you for your patience and partnership.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care Team
Posted Aug 14, 2026 - 10:45 MDT

Monitoring

Dear GHX Customer,

Fix Implemented: GHX has implemented a fix for the issue affecting access to the GHX Marketplace website, which was preventing some users from logging in to the applications.

• Marketplace Access — A fix has been deployed and is being applied. Access should be restored for most users at this time, but may take up to 30 minutes for others as the change propagates through DNS.

If you continue to experience issues after approximately 30 minutes, please clear your browser cache, restart your browser, and try again. If you continue to experience issues, please reach out to support, and they will escalate to the incident team immediately.

We apologize for any inconvenience and thank you for your patience and partnership.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care Team
Posted Aug 14, 2026 - 08:25 MDT

Identified

Dear GHX Customer,

We have identified an issue affecting access to the GHX Marketplace website, preventing some users from logging in to the applications. The issue has been identified, and the GHX Customer Care team is diligently working to resolve the problem. We will continue to provide updates until the issue is resolved.

As always, we are here to answer your questions and address any further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

GHX is committed to facilitating reliable supply chain transactions for the healthcare community. We understand the critical role we play in your business operations and sincerely apologize for any inconvenience this issue has caused you.

Thank you,

GHX Customer Care Team
Posted Aug 14, 2026 - 07:41 MDT
This incident affects: Prodigo.