Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.
Get email notifications whenever GHX - Customer Status - All creates, updates or resolves an incident.
Get text message notifications whenever GHX - Customer Status - All creates or resolves an incident.
The following update is being sent to all GHX Procure customers:
ISSUE SUMMARY:
GHX teams identified the issue causing users to receive errors when using the Add Items tab in GHX Procure. The technical team implemented a fix for this issue, and users should be able to utilize the Add Items tab in GHX Procure without issues.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Teams will continue to monitor the application, and we will provide an update early next week.
Thank you,
GHX Customer Care Team 1315 W Century Dr., Suite 100 Louisville, CO 80027 1.800.968.7449
Posted Apr 11, 2025 - 13:34 MDT
Monitoring
Good Afternoon,
The following update is being sent to all GHX Procure customers:
ISSUE SUMMARY:
GHX technical teams restarted the instances of GHX Procure, and users are reporting that some users can now utilize the Add Items tab in GHX Procure.
The team will continue to monitor this situation until we can verify that all users can access the Add Items tab in GHX Procure.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
We will continue to provide email updates until this issue is resolved.
Thank you,
GHX Customer Care Team 1315 W Century Dr. Suite 100 Louisville, CO 80027 1.800.968.7449
Posted Apr 11, 2025 - 09:57 MDT
Investigating
Good Afternoon,
The following update is being sent to all GHX Procure customers:
ISSUE SUMMARY:
GHX teams are currently troubleshooting an issue that is causing users to receive errors when trying to use the Add Items tab in GHX Procure. At this time, there is no Estimated Time to Repair (ETR).
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
We will continue to provide email updates until this issue is resolved.
Thank you,
GHX Customer Care Team 1315 W Century Dr. Suite 100 Louisville, CO 80027 1.800.968.7449