All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

Exchange visibility and login errors

Incident Report for GHX - Customer Status - All

Update

STATUS UPDATE:

At 8:25 AM Mountain Time on December 2nd, the GHX team identified an intermittent issue affecting customer document visibility and the availability of some GHX applications. As mentioned in our previous communications, GHX continues to monitor this situation and is providing the following status update to our customers:

- Transaction processing and delivery in the Exchange remain unaffected; all transactions are progressing in real-time.
- Document status updates within My Exchange and IBR transactions are displayed in real-time.
- GHX customer applications are fully available to our customers.
- Access to applications using GHX Single Sign-On is real-time.

Additional updates will be provided as needed.

If you have any questions or require further assistance, please contact GHX Customer Service at 1-800-YOUR-GHX (1-800-968-7449) or submit a service request online through the GHX Support tab on the GHX Community at [https://ghx.my.site.com/s/](https://ghx.my.site.com/s/).

Thank you,
GHX Customer Care
Posted Dec 02, 2025 - 17:00 MST

Update

STATUS UPDATE:

As of 8:25 AM Mountain Time on December 2nd, the GHX team identified an intermittent issue affecting customer document visibility and the availability of some GHX applications.

- Transaction processing and delivery in the Exchange remain unaffected; all transactions are progressing in real time.
- Document status updates within My Exchange and IBR transactions are now displayed in real-time.
- GHX customer applications are fully available and working as expected.
- Access to applications using GHX Single Sign-On is now real-time.

Our team will continue to monitor this situation and provide additional updates as needed.

If you have any questions or require further assistance, please contact GHX Customer Service at 1-800-YOUR-GHX (1-800-968-7449) or submit a service request online through the GHX Support tab on the GHX Community at [https://ghx.my.site.com/s/](https://ghx.my.site.com/s/).

Thank you,
GHX Customer Care
Posted Dec 02, 2025 - 09:59 MST

Update

STATUS UPDATE:

As of 8:25 AM Mountain Time on December 2nd, the GHX team identified an intermittent issue affecting customer document visibility and the availability of some GHX applications.

- Transaction processing and delivery in the Exchange remain unaffected; all transactions are progressing in real time.
- Document status updates within My Exchange and IBR transactions may be delayed up to 32 minutes.
- Some customers have reported receiving intermittent 504 errors while accessing some GHX applications.
- Access to applications using GHX Single Sign-On may be affected.

Our team will continue to monitor this situation and provide additional updates as needed.

If you have any questions or require further assistance, please contact GHX Customer Service at 1-800-YOUR-GHX (1-800-968-7449) or submit a service request online through the GHX Support tab on the GHX Community at [https://ghx.my.site.com/s/](https://ghx.my.site.com/s/).

Thank you,
GHX Customer Care
Posted Dec 02, 2025 - 09:00 MST

Monitoring

STATUS UPDATE:

As of 1:45 PM Mountain Time on December 1st, the GHX team identified an issue affecting document visibility in the My Exchange application.

- Visibility for IBR transactions and parked orders was restored by 4:45 PM Mountain Time.
- Document status updates within My Exchange are now displayed in real time.
- Transaction processing and delivery in the Exchange remain unaffected; all transactions are progressing in real time.
- Access to applications using GHX Single Sign-On has also been restored.

Our team will continue to monitor this situation throughout the evening.

If you have any questions or require further assistance, please contact GHX Customer Service at 1-800-YOUR-GHX (1-800-968-7449) or submit a service request online through the GHX Support tab on the GHX Community at [https://ghx.my.site.com/s/](https://ghx.my.site.com/s/).

Thank you,
GHX Customer Care
Posted Dec 01, 2025 - 16:47 MST

Identified

STATUS UPDATE:

At 1:45 p.m. Mountain Time on December 1st, the GHX team identified an issue affecting document visibility on the My Exchange application.

- Some users may experience limited visibility for IBR transactions and parked orders
- Document status update postings in My Exchange may be delayed up to 90 minutes
- Transaction processing and delivery in the Exchange is not impacted; all transactions are moving in real time

Our team is actively working to resolve this issue as quickly as possible, and we will provide updates until it is fully resolved. Please note that access to applications using GHX Single Sign-On is also affected, and users may encounter errors when trying to access these applications.

If you have any questions or need further assistance, please contact GHX Customer Service at 1-800-YOUR-GHX (1-800-968-7449), or submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Dec 01, 2025 - 15:45 MST

Update

We are continuing to investigate this issue.
Posted Dec 01, 2025 - 15:08 MST

Investigating

Good afternoon,

At 1:45 p.m. Mountain Time on December 1st, GHX teams identified an issue affecting document visibility on the Exchange. As a result, there may be limited visibility for IBR transactions, and some users may not be able to see parked orders.

Our team is actively working to resolve this issue as quickly as possible, and we will provide ongoing updates until it is fully resolved. Please note that access to applications using GHX Single Sign-On is also impacted, and users may encounter errors when trying to access these applications.

If you have any questions or need further assistance, please contact GHX Customer Service at 1-800-YOUR-GHX (1-800-968-7449), or submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you for your understanding.
Best regards,
GHX Support
Posted Dec 01, 2025 - 14:57 MST
This incident affects: My Exchange Provider, Procure, CCXpert, IBR (Intelligent Business Rules), NuVia, My Exchange Website, and Registration Center.