All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX Notification: Purchase Order History (POHX) Processing Delay

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customers,

GHX teams have continued to monitor the Purchase Order History (POHX) files throughout the day. There is currently no delay, and files are being processed in real-time.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care Team
Posted May 08, 2026 - 17:07 MDT

Monitoring

Dear GHX Customers,

ISSUE SUMMARY:
GHX teams identified and corrected an issue that caused a delay in processing Purchase Order History (POHX) files, beginning May 7 at approximately 2 PM MT. As a result, this may impact invoice smoothing, exception management, and matching within the application.

Impacted files are being processed, and we will continue to monitor throughout the day.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care Team
Posted May 08, 2026 - 09:16 MDT
This incident affected: eInvoicing Provider - Application.