All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX NOTIFICATION: My Exchange Website Unavailable for User Access
Incident Report for GHX - Customer Status - All
Resolved
Dear GHX Customer,

The issue that was preventing users from logging into the GHX 'My Exchange' application has been resolved. Users can log in to systems and resume normal operations.


* There has been no impact to EDI processing and delivery on the Exchange, all transactions continue to move through in real-time.


As always, we are here to answer your questions and address any further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.

GHX is committed to facilitating reliable supply chain transactions for the healthcare community. We understand the critical role we play in your business operations and sincerely apologize for any inconvenience this issue has caused you.

Thank you,

GHX Customer Care Team
Posted Oct 12, 2023 - 14:36 MDT
Investigating
Dear GHX Customer,

We have identified an issue that is impacting access to the 'My Exchange' website, preventing users from logging in to the My Exchange applications. The GHX Customer Care team is diligently working to identify the problem and we will continue to provide updates until the issue is resolved.

Below please find a summary describing what we know so far about this issue. We will be back in touch with an update on resolution status.


OVERVIEW

* At approximately 1:25 pm Mountain Time the My Exchange website experienced an error that is
preventing users from logging in

* Teams are working to resolve the issue as quickly as possible

* We will continue to provide updates until the issue is fully resolved


As always, we are here to answer your questions and address any further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.

GHX is committed to facilitating reliable supply chain transactions for the healthcare community. We understand the critical role we play in your business operations and sincerely apologize for any inconvenience this issue has caused you.

Thank you,

GHX Customer Care Team
Posted Oct 12, 2023 - 13:45 MDT
This incident affected: My Exchange (New).