All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX NOTIFICATION - Transaction Processing Delays

Incident Report for GHX - Customer Status - All

Resolved

UPDATE:

The issue that was causing a delay in transactions proccessing through the exchange has been resolved.
The exchange is processing documents in real time, and transactions impacted by the delay have been re-sent.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this status is fully resolved.

Thank you,

GHX Customer Care Team
Posted May 11, 2026 - 11:54 MDT

Monitoring

UPDATE:

GHX teams have identified and corrected the issue that caused a ~90-minute delay in transaction processing through the exchange. Transaction throughput has returned to real-time, and impacted transactions are being reprocessed.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this status is fully resolved.

Thank you,

GHX Customer Care Team
Posted May 11, 2026 - 11:23 MDT

Investigating

Good Morning,

ISSUE SUMMARY:

GHX teams are currently troubleshooting an issue that is causing delays of up to 90 minutes in transaction delivery, depending on when they arrived on the exchange. This includes Orders, Order Confirmations, Advanced Ship Notifications and Invoices.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
Posted May 11, 2026 - 10:44 MDT
This incident affected: Exchange Transaction Processing.