All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX Notification: Data Connect Item Recommendations
Incident Report for GHX - Customer Status - All
Resolved
Dear GHX Customer,

The issue impacting Item Recommendations, Catalog Search, & Duplicate Review functions has been resolved.

As always, we are here to answer your questions and address any further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.

GHX is committed to facilitating reliable supply chain transactions for the healthcare community. We understand the critical role we play in your business operations and sincerely apologize for any inconvenience this issue has caused you.

Thank you,

GHX Customer Care Team
Posted Apr 24, 2024 - 13:04 MDT
Identified
Dear GHX Customer,

GHX teams have identified an issue that is preventing some but not all Item Master items from being recognized in the system. This is impacting Item Recommendations, Catalog Search, and Duplicate Review functions.

We are working to resolve this issue as quickly as possible and will provide updates until these functions are fully restored.

As always, we are here to answer your questions and address any further concerns. Please don’t hesitate to contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.

GHX is committed to facilitating reliable supply chain transactions for the healthcare community. We understand the critical role we play in your business operations and sincerely apologize for any inconvenience this issue has caused you.

Thank you,

GHX Customer Care Team
Posted Apr 22, 2024 - 15:30 MDT
This incident affected: Data Connect.