Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.
Get email notifications whenever GHX - Customer Status - All creates, updates or resolves an incident.
Get text message notifications whenever GHX - Customer Status - All creates or resolves an incident.
GHX has resolved the issue that caused delays in the delivery of automatic email notifications from My Exchange applications. Any notification that should have been generated between 11:05 PM MT on November 17, 2025, and 3:00 PM MT on November 18, 2025, cannot be regenerated. All notifications for documents created after 3:00 PM MT on November 18 will be generated and sent as expected. Document processing through the Exchange and My Exchange web access was not impacted.
If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at www.ghx.com/community.
Thank you. GHX Customer Care
Posted Nov 18, 2025 - 16:22 MST
Investigating
Dear GHX Customer,
Issue Summary: GHX is currently troubleshooting delays in the delivery of automatic email notifications from My Exchange applications. At this time, only the delivery of the email notifications has been impacted. Document processing through the Exchange and My Exchange web access is not impacted. GHX is working to resolve this delay as soon as possible.
If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at www.ghx.com/community.
Thank you. GHX Customer Care
Posted Nov 18, 2025 - 13:01 MST
This incident affected: My Exchange Provider, Exchange Transaction Processing, IBR (Intelligent Business Rules), and My Exchange Website.