All Systems Operational

About This Site

Obtain information regarding the status of GHX products and subscribe to receive alerts regarding GHX product status by clicking the "Subscribe to Updates" button.

GHX NOTIFICATION - Transaction Processing Delays

Incident Report for GHX - Customer Status - All

Resolved

Good Afternoon,

As of 1 p.m. MST, the GHX Exchange is processing all documents in real time. This includes Orders, Order Confirmations, Advanced Ship Notifications, and Invoices. There are a number of failed documents that the team is addressing at this time.

Access to GHX's applications has also been restored.

We will continue to monitor and provide updates as they become available.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/ .

 Thank you,

 GHX Customer Care Team
 1315 W Century Dr. Suite 100
 Louisville, CO 80027
 Support@GHX.com
 1.800.968.7449
Posted Feb 25, 2026 - 13:25 MST

Update

Good Afternoon,

ISSUE SUMMARY:

Beginning at 10:45 a.m. MST, GHX resources began troubleshooting an issue causing transaction processing delays.  Currently, the GHX Exchange is experiencing transaction processing delays of up to 60 minutes.  This includes Orders, Order Confirmations, Advanced Ship Notifications, and Invoices.

Access to GHX applications may also be impacted by these processing delays. Affected applications include: My Exchange, IBR, Metatrade, NuVia, and eInvoicing.  Orders processed through GFax are also delayed.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Feb 25, 2026 - 12:23 MST

Investigating

Good Afternoon,

ISSUE SUMMARY:

GHX teams are currently troubleshooting an issue that is causing transaction processing delays of up to 30 minutes. This includes Orders, Order Confirmations, Advanced Ship Notifications, and Invoices.

Access to GHX applications may also be impacted by these processing delays. Affected applications include: My Exchange, IBR, Metatrade, NuVia, and eInvoicing. Orders processed through GFax are also delayed.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Feb 25, 2026 - 11:56 MST
This incident affected: My Exchange Provider, G-Fax, Exchange Transaction Processing, Procure, CCXpert, IBR (Intelligent Business Rules), eInvoicing Supplier, eInvoicing Provider - Application, NuVia, MetaTrade, My Exchange Website, Registration Center, and Web Direct.